Jump to content

Recommended Posts

My facility is 6 upgrades behind for our bb software. Does anyone know of any regulatory body that requires that you are on the most current software version?

Share this post


Link to post
Share on other sites


Sorry I don't know - but it might depend on what the upgrades were about.  Any patient/system safety issues would be high priority.  Other stuff, not so much probably.

Share this post


Link to post
Share on other sites

I don't know of any regs or accreditation standards, however your software vendor may have a stipulation about how many versions users can be behind before they stop supporting the software.  You might check with them.

Share this post


Link to post
Share on other sites

Our vendor was cited by FDA (many years ago) for allowing customers to run older version of their software, regardless of it being supported.

Share this post


Link to post
Share on other sites

tcoyle makes an excellent point, your vendor may stop supporting your version if you don't take the recommended upgrades.  I support 14 hospital BBs and I know upgrading and validating is expensive.  There are reasons software is updated, your lab director or IT department needs to allocate funds to get this done for you, tie it to patient safety!

I don't know of any mandatory FDA reg that says you must update but it's just like running your car, it needs maintenance if it is to perform well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.